Archiv für die ‘Linux’ Kategorie

nautilus-open-terminal does not open terminals?

Samstag, Mai 8th, 2010

For about half a year or more I have been using Ubuntu with a defunct nautilus-open-terminal addition to the Nautilus file manager.  It adds a shortcut to the context and file menu of Nautilus reading „Open in terminal“ or something like that (in German it is „In Terminal öffnen“).

However, when I clicked it, no terminal used to pop up anymore.  Today I once dealt with the problem again and changed the Gnome default application for terminal emulation to xterm and was surprised: the open terminal shortcut worked again!

Well, the solution is that gnome-default-applications-properties (System > Settings > Default Applications) did not correctly update the command line option for the respective terminal emulator.  xterm takes a „-e“ (which was set here) to execute commands, as nautilus-open-terminal presumably does, but gnome-terminal wants a „-x“ for this (-e exists as well but wants the command quoted as a string).  The default applications tool did not update this field.

So I had to correct the parameter myself:

  • launch gconf-editor
  • navigate to /desktop/gnome/applications/terminal
  • change value of key exec_arg to -x for gnome-terminal or to -e for xterm

What is left to wonder about is, why it did not work for me on this computer but it did on my laptop.  I assume I have never switched the default terminal there and the correct paramter for the default gnome-terminal has thus been save.  I did not find a bug report on Launchpad either.  Maybe I will file one but before I do so I might consider updating to Lucid, Ubuntu’s latest version…

Update:  After the update to Lucid, it works correctly via the GUI as well.

Direct Rendering mit Ubuntu Intrepid Ibex und fglrx

Sonntag, Februar 1st, 2009

Neulich musste ich erstaunt feststellen, dass mir der fglrx-Treiber (der proprietäre Grafikkartentreiber für AMD/ATI-Chips) unter Ubuntu Intrepid Ibex gar keine 3D-Beschleunigung brachte. Compiz funktionierte trotzdem, daher bemerkte ich das bis dahin nicht. Nach kürzlichen Updates erschien mir dann auch das Verschieben von Fenstern mit Metacity nicht mehr flüssig genug und es war sogar mit dem freien Treiber radeonhd schöner anzuschauen.

Das Kommando glxinfo förderte zu Tage, dass zwar die 3D-Implementierung des fglrx-Treibers verwendet wurde, jedoch das Direct Rendering abgeschaltet blieb (die Umgebungsvariable LIBGL_ALWAYS_INDIRECT wurde vom Compiz-Fusion-Icon beim Start gesetzt). Außerdem brachen mir einige OpenGL-Programme beim Start gar mit einer Fehlermeldung ab, von der auch andere Benutzer zu berichten wussten. So konnte es nicht bleiben, eine Lösung musste her. (mehr …)

Kein Zugriff mehr auf virtuelle Terminals (tty1-6) in Ubuntu Gutsy Gibbon: Lösung

Samstag, März 22nd, 2008

Seit geraumer Zeit war es bei meinem Notebook so, dass ich durch drücken von Strg+Alt+F1 bis F6 nicht etwa auf benutzbare Linux-Kommandozeilenboxen kam, sondern auf schwarze Bildschirme mit blinkendem Cursor oben links. Sehr hilfreich. Heute entschloss ich dann endlich mal, dem ein Ende zu bereiten und bin auch fündig geworden. (mehr …)

Tastenkombinationen von Metacity weg

Dienstag, Februar 19th, 2008

Hallo,

ich hab seit letzter Woche ein neues Notebook, aber dazu vielleicht später mehr.

Jedenfalls hatte ich heute das Problem, dass meine Tastenkombinationen für den Fenstermanager nicht mehr funktionierten. Das war nach einem Missglückten versuch des Ruhezustandes und auch einer dummen Aktivierung der gutsy-backports in den Ubuntu-Paketquellen und eines Updates aus diesen.

Die Lösung, auf die mich letztendlich ein freundlicher Linuxer aus #ubuntu-de (irc.freenode.net) brachte, war, metacity neu zu installieren. Dazu muss man das metacity-common Paket entfernen. Dies deinstalliert auch den halben GNOME-Desktop, daher muss man den hinterher auch wieder installieren. Am besten installiert man nach dem Entfernen Metacitys einfach das Paket ubuntu-desktop erneut, welches alle Software, die zur Ubuntu-Distribution gehört, wieder installiert.

Vorsicht, wer Pakete daraus ersetzt hat (wie z. B. ich network-manager durch wicd), die ersetzten Pakete werden so auch wieder installiert und müssen erneut ersetzt werden.

Das soll nur eine kleine Hinweisgebung sein. Sollte jemand fragen haben, oder etwas zu ergänzen sein, sind Kommentare willkommen.

Endlich wieder Surround

Montag, Dezember 3rd, 2007

Hallo Leute!
Einigen wenigen dürfte ich von meinem Problem mit dem Sound unter Linux berichtet haben. Unter Windows hatte ich mir meine fünf Satellitenlautsprecher so eingestellt, dass die Geräusche alle ein wenig nach hinten verschoben werden, denn die hinteren Lautsprecher würden sonst ja fast gar nicht frequentiert.
Unter Linux stand ich dann aber vor dem Problem, dass ich entweder Surroundsound für ein Programm haben konnte, und die anderen dann stumm sein mussten, oder alle Sound bekommen, dafür aber nur Stereo. Der Grund für die Masche, dass nur ein Programm gleichzeitig spielen konnte, ist der, dass immer nur ein Programm gleichzeitig auf die Hardwareressource ‚Soundkarte‘ gleichzeitig zugreifen kann bzw. dies beim Betriebssystem beantragen kann. Um trotzdem mehrere Programme Sound ausgeben zu lassen bedarf es eines Programmes, das alle Soundanfragen entgegen nimmt, alles zusammenmixt und dann als das Programm diesen Mix auf der Soundkarte ausgibt. Alternativ könnte man sich auch eine Soundkarte kaufen, die das hardwareseitig unterstützt, aber weder habe ich so eine, noch möchte ich mir so was kaufen. Diese ganze Problematik wurde mir unter Windows einfach verschwiegen, obwohl es dort wahrscheinlich ganz ähnlich abläuft. Nur bekommt man davon unter Windows natürlich nichts mit und man darf sich seinen Soundserver (das ist das Mixprogramm) nicht aussuchen. Vermute ich… bei Windows kann man ja nicht rein gucken.
Jedenfalls funktionierte die mehr oder weniger hauseigene Lösung des Mixens über ALSA (Advanced Linux Sound Architecture) nur mit 2 Kanälen.

Seit ca. einem Monat benutze ich Pulseaudio als Soundserver, da ich 1. mal wieder einen Surroundversuch starten wollte und 2. das in der kommenden Ubuntuversion sowieso zum Standard werden wird. Mein Versuch scheiterte wieder und ich weiß schon gar nicht mehr wieso… jedenfalls hab ich es heute endlich geschafft, das ganze zum Laufen zu bewegen! Ich habe jetzt endlich wieder 5.1 Surround Sound für alle Programme!

Nun möchte ich noch meine Lösung hier niederschreiben. (mehr …)